• Meta — Stuff about veekun. Praise, complaints, praise, praise, more praise, and so on.
  • Problem in starting site

I've followed the steps to use your code on my server, but when I access the site I get the following errors on shell:

Error - : Cant locate template for uri u'/widgets/user_state.mako' [...] TemplateLookupException: Cant locate template for uri u'/widgets/user_state.mako'

In widgets/ folders those files don't exist. Is there a way to add this? I've jumped something in site setup?


Which steps did you follow? There are a few versions floating around. I believe is the most up-to-date.

The file you're looking for is part of the users plugin; it should be at spline/splinext/users/templates/widgets/user_state.mako. If it's not there then something is wrong with your checkout; you might have an old copy of the code. If it is there then something else is wrong.

Note that the pokedex plugin doesn't require the users plugin; if you're just trying to run the pokedex then you should just disable all the other plugins.


Hi, thanks for reply. I've tried to reinstall and reconfigure the script in a new server, and now that problem is solved :) Now, unfortunately, there's another problem. When I run "bin/python develop" (I used virtualenv) within "spline-pokedex" directory, shell shows me the following error:

Searching for pokedex Reading Couldn't find index page for 'pokedex' (maybe misspelled?) Scanning index of all packages (this may take a while) Reading No local packages or download links found for pokedex Best match: None Traceback (most recent call last): stack AttributeError: 'NoneType' object has no attribute 'clone'

(stack is called functions list)

I've run command after having configured pokedex and spline. It seems that it can't find "pokedex" package at, and in fact there is no package named "pokedex" at that address. How can I solve? :(


No one can help me?


Pokedex isn't at pypi, but that's okay. Since you already installed pokedex, setup shouldn't even be looking for it at pypi. It should see that it's already installed.

Maybe pokedex didn't install correctly? Can you import pokedex successfully from the python interpreter?


Maybe I was wrong to create virtualenv. Now I created it in main directory, and not in projects single directories.

Now I'm trying to startup the site with "paster serve --reload development.ini" command. What I don't understand is where I have to create development.ini. I run the following commands in main directory (dex/):

-> bin/paster make-config spline development.ini -> (edited properly development.ini) -> bin/paster setup-app development.ini

So, development.ini is in main directory. Then, from Veekun directory: -> ../bin/paster serve --reload ../development.ini

Now shell returns this error: "OSError: [Errno 2] No such file or directory: '/home/site-name/dex/data/pokedex-index'"

I noticed that in development.ini there's a line called "cache_dir", I assigned it the following value: "%(here)s/data" but nothing changes. Actually that directory doesn't exist. How can I solve?


Sorry for double post. Finally I resolved that problem too :)

I created development.ini inside veekun directory, then I started up the site. Now the problem is that URL is not reachable. Maybe I have to add server IP in development.ini? The [server:main] part looks like so:

[server:main] use = egg:Paste#http host = port = 5000

Even if I add my server IP, site is not reachable...